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1
Introduction

This Infocast User Guide provides the information needed to operate the 
Infocast Client application. The topics in this chapter include:

Chapter Topics • What is Infocast?
• How this Guide is Organized
• Using this Guide

What is Infocast?

Infocast is a productivity-based tool designed to allow NEC contact 
center users to view real-time queue statistics on the desktop. This 
enables users to react immediately to changes in call volume and agent 
availability to better serve customers.

Infocast gives users access to critical contact center statistics in a small 
window right on their workstations. While NEC's Virtual Wallboard 
application duplicates hardware wallboard statistics on the desktop, 
Infocast customizes this information for each user by displaying 
information that pertains to call activity for skill sets (splits) unique to 
that user.

Infocast displays call center information and statistics, such as:

• Abandoned percentage
• Calls in queue
• Grade of service
• Longest waiting call
• Number of agents in ready, break, work, and talk modes
• Split name
• Split number
• Total number of agents logged in

Using a local area network, Infocast links to an existing Global Navigator 
platform connected to a CallCenterWorX ACD to receive and display the 
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call center real-time queue statistics on each agent’s personal computer 
running the Infocast client.

How this Guide is Organized

Chapter 1
Introduction

This chapter provides a brief overview of the Infocast application, along 
with how this guide is organized and the document conventions. 

Chapter 2
Using Infocast

This chapter shows you how to perform the most common functions in 
Infocast, including how to use the Infocast online Help. 

Using this Guide

This guide is designed to make Infocast easy to use. This guide contains 
examples of installation screens and step-by-step instructions for the 
procedures you need to perform.

Document Conventions
This guide uses the following document conventions listed in Table 1-1:

Table 1-1  Document Conventions 

REFERENCE

Refer to the NEC Infocast Installation Guide for information on installing and 
configuring Infocast.

When you see It means Example

Boldfaced 

• Field names
• Button names
• Drop-down list names

• Commands, keywords, or 
other user input

Enter the ID in the Name field.
Click Save.
Select the names from the 
Employees drop-down list.
Enter login admin at the command 
prompt. 

Capitalized 

• Menu names
• Window names

• Dialog box names

From the File menu, choose Save.
From the Directory window, select 
Edit > Modify. 
Click OK to save and close the 
Account Properties dialog box.

Menu > Submenu
(boldfaced font)

• Menu paths Select Edit > Modify.

CTRL+S
CTRL+Shift+S

• Shortcut keys Press CTRL+S to save your changes.
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Procedures
Step-by-step instructions are numbered. Simply follow the numbered 
steps to perform the desired function.

Sometimes in step-by-step instructions, you will have more than one 
option to complete the task. These options are presented as shown in 
the following example:

Step  1 Do one of the following to add a new employee to the Employee 
directory:

—Select the desired employee from the Name field and click Add.
—Double-click the desired employee from the Name field.
—To select all of the available names, click Add all.

Keyboard Conventions
The keys that may be used for this application are:

Table 1-2  Keyboard Conventions

F2 • Function keys Press F1 to access the online Help. 

Click
Right-click

• Click the left mouse button
• Click the right mouse button

Click OK to save your changes. 
Right-click and select Delete from the 
shortcut menu.

When you see It means Example

Key Action
Arrow keys Scrolls among options within a menu or field.

Backspace Erases the character to the left of the cursor. 

Enter Accepts a selection or field entry. 

ESC Exits the current screen or action and moves to the previous screen 
or action.

Tab Moves forward through fields and options.

Shift+Tab Moves backward through fields and options.

CTRL+Tab Moves forward through tabs.

CTRL+Shift+Tab Moves backward through tabs.
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2
Using Infocast

The Infocast Client application operates on a personal computer. This 
chapter describes the Infocast Client features and includes these topics:

Chapter Topics • Getting Started with Infocast
• Configuring the Split Data Display
• Setting the Infocast Options

Getting Started with Infocast

This section details the Infocast Client window, and contains the 
following procedures:

• Setting up the Infocast Client Connection
• Starting and exiting the Infocast Client application
• Connecting to and disconnecting from the server.
• Accessing the Infocast online Help.

Operating Modes
Infocast can be configured by the system administrator to operate in 
one of two following modes:

Anonymous mode The Anonymous operating mode lets you start Infocast and receive 
statistics without entering an Agent ID and password. If Infocast is 
using Anonymous mode, the Infocast window is displayed immediately 
after launching the Infocast Client application from the desktop. 

Secure mode The Secure operating mode requires an agent to log in before receiving 
and displaying statistics. When this mode is selected, Infocast prompts 
the agent to enter an ID (for ACD agents) and password (for resource 
users) to access the Infocast window. 

NOTE

Anonymous mode, which is also known as No Agent ID mode, is the default 
operating mode.
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Setting up the Infocast Client Connection
Before running the Infocast Client for the first time, you must configure 
the connection to the server. Use the following steps to configure the 
Infocast Client’s server connection.

Step  1 From the Windows Start menu, select Programs > NEC Infocast > NEC 
Infocast Setup. The Infocast Setup dialog box displays (Figure 2-1).

Figure 2-1  Infocast Setup dialog box

Step  2 Enter the Server Name (or IP address) and Server Port of the Infocast 
Server (Global Navigator Server).

Step  3 Select Default if your server uses the default server port. To use a 
different port assignment, uncheck Default and enter the port number 
you wish to assign.

Step  4 Click OK to save the settings and close the dialog box.
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Starting and Connecting to Infocast (Anonymous mode)
If your server is configured to run in Anonymous mode, do the following 
to start the Infocast Client application and connect to the server:

Step  1 From the Windows desktop, select Start > Programs > NEC Infocast > 
NEC Infocast. If Infocast is configured to run in Anonymous mode, the 
Split Selection dialog box displays (Figure 2-2 if only a single node is 
available, Figure 2-3 if multiple nodes are available).

Figure 2-2  Split selection dialog box (single node available)
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Figure 2-3  Split selection dialog box (multiple nodes available)

Step  2 If your system contains multiple nodes, use the Node: dropdown menu 
to select a node whose statistics you wish to display in the Client window. 
A list of that node’s available splits displays in the Splits pane.

Step  3 Do one of the following:

— If your system contains a single node:
Click to select the desired splits. You can select multiple splits by 
pressing the CTRL key while clicking on the desired splits. To select a 
range of splits, hold the SHIFT key while clicking on the first, then the 
last split in the range. You can also use the Select All or Clear All 
buttons to select all or none of the listed splits.

— If your system contains multiple nodes:
Click to select the desired splits displayed in the Available Splits pane. 
You can select multiple splits by pressing the CTRL key while clicking 
on the desired splits. To select a range of splits, hold the SHIFT key 
while clicking on the first, then the last split in the range. You can also 
use the Select All or Clear All buttons to select all or none of the 
listed splits. 

Then, click  to move your selections to the Selected Splits pane. 

You can also click  or Remove All to remove splits from the 
Selected Splits pane.

Step  4 Click OK. Infocast displays the Client window (Figure 2-7).
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Starting and Connecting to Infocast (Secure mode)
If your server is configured to run in Secure mode, do the following to 
start the Infocast Client application and connect to the server:

Step  1 From the Windows desktop, select Start > Programs > NEC Infocast > 
NEC Infocast. The Login dialog box displays (Figure 2-4 if only a single 
node is available, Figure 2-5 if multiple nodes are available).

Figure 2-4  Login dialog box (single node available)

Figure 2-5  Login dialog box (multiple nodes available)

Step  2 Enter your agent ID. If your system contains multiple nodes, use the 
Node dropdown menu to select a node whose statistics you wish to 
display in the Client window.

Step  3 Click OK when you are done. One of the following occurs:

—If you are an ACD agent, the Infocast Client window displays 
(Figure 2-7).
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—If you are a resource user, the Password dialog box displays 
(Figure 2-6). Enter your password and click OK. The Infocast Client 
window displays (Figure 2-7).

Figure 2-6  Password dialog box

Figure 2-7  Infocast Client window (Connected to the Server)
 

About the Infocast Client Window
The Infocast Client window contains the following components:

Title Bar The Title Bar displays the name of the application, the connection 
status, and indicates the operating mode configured.

Menus The Menu bar in the Infocast Client window (Figure 2-7) contains the 
available menus. Table 2-1 describes the menu options contained in the 
menus.

NOTE

In the Split column, the first digit represents the tenant number, while the remaining 
digits represent the split number.

TIP

You can hide or show the Menu Bar by selecting View > Menu, by pressing 
CTRL+M, or by double-clicking on the Menu Bar. Once you hide the menu, use 
CTRL + M to re-display it.
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Table 2-1  Infocast Client Menus 

Accessing Online Help
Online Help is available for Infocast. The online Help contains a Contents 
listing, an Index, and a Search feature. Use these features to navigate 
to the desired Help topic. 

To launch the Infocast online Help, do the following:

Step Select Help > Index. 

Exiting Infocast
Use the following steps to disconnect from the server and exit the 
Infocast Client application. 

Step  1 Select File > Exit or press ALT + F4. The Infocast disconnect 
confirmation dialog box displays (Figure 2-8). 

Menu Options

File
• Select the splits to monitor (in Anonymous mode only).
• Exit the Infocast Client and disconnect from the server. 

Settings

• Change your login password.
• Configure the Infocast Client window to “pop-up” when the system 

triggers Level 1 or Level 2 alarms.
• Specify whether the Infocast Client sounds an audible alert when 

the system triggers Level 1 or Level 2 alarms.
• Specify how often the Infocast Client display refreshes. 
• Configure the text and background colors the Infocast Client uses 

to display Level 1 and Level 2 alarms.
• Select the font size, type style, and size the Infocast Client uses 

to display statistics.
• Automatically re-size the Infocast Client window to fit the data 

displayed.

View

• Select which data columns display in the Infocast Client window.
• Select which of the available splits assigned to the agent will 

display in the Infocast Client window.
• Show or hide the Menu Bar.
• Specify whether the Infocast Client application remains on top of 

all other applications running on your computer.

Help
• Access the online Help. 
• View information about the Infocast Client version installed.
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Figure 2-8  Disconnect confirmation dialog box

Step  2 Click OK. The Infocast Client application disconnects from the server 
and returns you to the Windows desktop.

Configuring the Split Data Display

Each agent can select which of the available splits display on their 
personal computer, as well as select the information to display about 
each split. This section describes the following procedures:

• Selecting the splits to display
• Selecting the split data to display
• Changing the split order

Selecting the Splits to Display
An agent can select which of the available splits to display in the 
Infocast Client window. To do so, use the following steps:

Step  1 Select View > Splits. The available splits display in the menu 
(Figure 2-9). 

Figure 2-9  Selecting splits to display
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Step  2 Select the splits you want to view. The Infocast Client window updates to 
display the selected splits. To turn off a split’s display, select it again from 
the menu.

Selecting the Split Data to Display
An agent can select which columns of data to display on the Infocast 
Client window. To do so, use the following steps:

Step  1 Select View > Columns. The available split data columns display in the 
menu (Figure 2-10). 

Figure 2-10  Selecting data columns to display

Step  2 Select the split data columns you want to view. The Infocast Client 
window updates to display the selected columns. To turn off a column’s 
display, select it again from the menu

Changing the Split Display Order
You can change the order in which the splits are displayed at any time 
while you are connected to the server. 

Use the following step to change the displayed splits order.

NOTE

You can rearrange the columns of split data by clicking on the column heading and 
dragging the column to a different location on the window.
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Figure 2-11  Changing the split display order

Step Select the desired split and drag it to the new location in the split order. 
The Infocast Client window updates to show the splits in the selected 
order.

Setting the Infocast Options

The Settings menu contains the settings that allow you to customize the 
Infocast Client environment to meet your individual preferences. These 
settings control how the Infocast Client looks, feels, behaves, and 
sounds.

To configure the settings, select the Settings menu and choose the 
desired options, as described in Table 2-2. 

Table 2-2  Settings Menu Options

Option Action

Change Password Lets you change the password you use to log in to the Infocast 
Client. (Only available for resource users in Secure mode.)

Popup Lets you specify whether the Infocast Client, if currently minimized, 
restores on your screen when it receives a Level 1 or Level 2 alarm. 

Sound Use this option to specify whether the Infocast Client sounds an 
audible alert when either a Level 1 or Level 2 alarm triggers. 

Refresh Use this option to specify how long Infocast waits to refresh the 
statistics in the Client window.

Alarm Colors... Lets you select the background color and text color of a cell 
displaying a Level 1 or Level 2 alarm in the Client window.

Font... Lets you select the font size, typeface, and style Infocast uses to 
display information in the Client window.

Autosize Table Use this option to immediately shrink or expand the Client window 
so it accomodates the amount of data displayed.
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Changing a Password
Use the following steps to change your password.

Step  1 Select Settings > Change Password. The Change Password dialog 
box displays (Figure 2-12). 

Figure 2-12  Change Password dialog box 

Step  2 Enter your old password.

Step  3 Enter your new password, then enter it again to verify.

Step  4 Click OK when you are finished to save your changes and return to the 
Infocast Client window.

NOTE

The Change Password option is available only to resource users when Infocast is 
configured to run in Secure mode. See “Operating Modes” on page 2-1.
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For additional information or support on this NEC product,
contact your NEC representative.
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