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1
Introduction 

This chapter provides information on the following topics.

Chapter topics • About This Guide
• How This Guide is Organized
• Using This Guide

About This Guide

This manual describes the procedures required to install and implement 
the Global Navigator 6.0 server. This version of Global Navigator is for 
use with the Red Hat Enterprise Linux ES Version 3 operating system 
and uses the MySQL relational database version 4.0.20-standard. 

NOTE

Global Navigator 6.0 is NOT compatible with SCO UNIX or Open Server.

IMPORTANT

Perform the procedures in the appropriate sections and subsections in the order
suggested. It is important that you follow all procedures in the sequence
listed.
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How This Guide is Organized

Chapter 1
Introduction

This chapter contains a description of Global Navigator and the 
conventions used in this document. Also included is a list of other 
important documents you should be familiar with.

Chapter 2
Requirements

This chapter lists the materials and information you need to perform the 
Global Navigator installation.

Chapter 3
Installation

This chapter includes procedures for installing the various components 
of Global Navigator, including the Linux Red Hat operating system and 
the Global Navigator server software. Also included are information and 
procedures needed to properly secure the server. 

Chapter 4
Database and Hardware

Conversion

This chapter describes how to perform a database or hardware 
conversion from Global Navigator 3.x/4.x/5.x to Global Navigator 6.0.

Chapter 5
Peripherals

This chapter includes procedures for installing and configuring the 
Modem, Digiboard, Wallboard, and the Webmin administration program

Chapter 6
Troubleshooting and

Maintenance

This chapter provides information on troubleshooting and maintenance 
of the Global Navigator 6.0 Server.

Using This Guide 

This guide is designed to help make Global Navigator easy to install. 
This guide contains examples of screens and step-by-step instructions 
for the procedures you need to perform.

Document Conventions 
This guide uses the following document conventions listed in Table 1-1.

Table 1-1  Document Conventions 

When you see It means Example

Boldfaced 

• Field names
• Button names
• Drop-down list names

• Commands, keywords, or 
other user input

Enter the ID in the Name field.
Click Save.
Select the names from the 
Employees drop-down list.
Enter login admin at the command 
prompt. 
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Procedures 
Step-by-step instructions are numbered. Simply follow the numbered 
steps to perform the desired function.

Sometimes in step-by-step instructions, you will have more than one 
option to complete the task. These options are presented as shown in 
the following example:

Step  1 Do one of the following to add a new employee to the Employee 
directory:

—Select the desired employee from the Name field and click Add.
—Double-click the desired employee from the Name field.
—To select all of the available names, click Add all.

Related Documents

In order to gain a full understanding of Global Navigator you should be 
familiar with the following documents, available on the Global Navigator 
/ Net ACD Documentation CD (Stock # 244408).

• GNAV Pro Reports Manual 
• GNAV Pro Quick Reference Guide
• Network ACD Configuration Guide
• INFOCAST Administration Guide
• INFOCAST Installation Guide
• INFOCAST User Guide
• Virtual Wallboard Installation Guide
• Virtual Wallboard Users Guide

Capitalized 

• Menu names
• Window names

• Dialog box names

From the File menu, choose Save.
From the Directory window, select 
Edit > Modify. 
Click OK to save and close the 
Account Properties dialog box.

Menu > Submenu
(boldfaced font)

• Menu paths Select Edit > Modify.

CTRL+S
CTRL+Shift+S

• Shortcut keys Press CTRL+S to save your changes.

F2 • Function keys Press F1 to access the online help. 

Click
Right-click

• Click the left mouse button
• Click the right mouse button

Click OK to save your changes. 
Right-click and select Delete from the 
shortcut menu.

When you see It means Example
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2
Requirements

This chapter includes a list of the items and information needed to 
install and operate the Global Navigator 6.0 Server, including:

Chapter topics • Server Hardware Requirements
• Software Requirements
• Required Information
• Optional Equipment

Server Hardware Requirements

Table 2-1 lists the server configuration requirements.

Table 2-1  Global Navigator Server Requirements

NOTE

If you are upgrading to Global Navigator 6.0, your server must have at least 1 GB of 
memory (RAM). The 120Le and 120Lf originally shipped with 256 MB of RAM. 
Additional RAM may be purchased from NEC Unified Solutions, Inc. You do not need 
to upgrade the 120Le or 120 Lf processors.

Components Minimum
Memory (RAM) 1 GB

Processor 2.4GHz CPU

Available Hard Disk Space 36 GB

Floppy Drive 3.5" 1.44 MB Floppy Drive

CD ROM Drive 40X Internal CD-ROM Drive

Network Interface Cards (NIC) 
with network connection 2 10 Mbps or 100 Mbps Ethernet cards .

MS Mouse Two-button mouse.

Keyboard 105 Keyboard

Modem U.S. Robotics 56k Fax modem

Tape Backup 20/40GB SCSI DAT 4 Tape backup device
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Software Requirements

Table 2-2 lists the software requirements for the Global Navigator 
server.

Table 2-2  Global Navigator Software Requirements

Required Information

Table 2-3 lists the information required to install the Global Navigator 
server.

Table 2-3  Required Information

NOTE

System requirements for Global Navigator Network ACD call for an operative PBX 
with CallCenterWorX ACD system programming (either CallCenterWorX–Business 
or CallCenterWorX–Enterprise) already in place.
System requirements for the particular PBX being used with a CallCenterWorX 
application will be found in the appropriate documentation set for that PBX. 

Component Requirement

Operating System Red Hat Enterprise Linux ES version 3 (kernel version linux-2.4.21-4.EL) 
Install CD-ROM set

Global Navigator The latest Release Global Navigator 6.0 Server CD-ROM

Webmin Webmin CD-ROM

NOTE

Only GNAV Pro  6.0 can be used with the Global Navigator 6.0 Server. You must 
install the client using the GNAV Pro  6.0 CD.

Component Requirement
Licensing Security Key 

(USB / Parallel)
This should include the security device number, serial number(s), and 
activation key(s)

ACD IP Address The correct IP address of the ACD server.
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Optional Equipment

Table 2-4 lists the optional equipment you can use with Global Navigator 
server.

Table 2-4  Optional Equipment

Component Requirement

Digi board
DIGI AccelePort Xem System (Ports/8em RJ-45) board (1) 
or
DIGI AccelePort Xp System (4 port/ RJ-45) PCI board (1)

SPECTRUM Wallboard

The following Spectrum Wallboards are supported:
• 1512R
• 1512C
• 1022C
• 214C
• 3214R
• 3614C
• 3614R
• 3024C
• 3024R
• Silent Radio 
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3
Installation

This chapter contains procedures for the following:

Chapter topics • Installing the Linux Operating System
• Installing the Initio SCSI Driver (for Tape Backup)
• Installing the Global Navigator Server Software
• Securing the Server

Installing the Linux Operating System

Use the following procedure to install the Red Hat Enterprise Linux 
operating system.

Step  1 Power on the server.

Step  2 Insert the Red Hat Enterprise Linux Installation CD 1 of 4 into the CD-
ROM drive. The Server will boot to the CD. The first screen will ask for 
the type of installation. 

Step  3 Select Install Red Hat in Graphical Mode and press Enter. The 
Welcome to Red Hat Enterprise Linux screen displays.

Step  4 Click Next to continue. The Language Selection screen displays. 

CAUTION

Unless a dialog box is waiting for your input, do not press any keys during the 
installation process (doing so may result in unpredictable behavior). 

IMPORTANT

If you are migrating from Global Navigator 5.x to Global Navigator 6.x, you must 
convert your database by completing the database conversion procedures in 
“Database Conversion for 5.x Database” on page 4-7 before completing the 
procedures in this chapter.

IMPORTANT

Prior to the installation of the Red Hat Enterprise Linux operating system, make sure 
that the server BIOS BOOT settings are as follows:
Floppy; CDROM; Hard-drive

This can be done, by pressing the F2 key during initial boot of the server, and then 
following the system menu for Boot sequence setup.
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Step  5 Verify that English is the only language selected. 

Step  6 Click Next. The Keyboard Configuration screen displays. 

Step  7 Verify that U.S. English is the only choice selected and click Next. The 
Mouse Configuration screen displays.

Step  8 Select Wheel Mouse PS/2 and click Next. The Disk Partitioning screen 
displays. 

Step  9 Select Manually partition with Disk Druid and click Next.
If a warning screen pops up click Yes. The Disk Setup screen displays.

Step  10 Click New.

Step  11 Type /boot in the Mount Point field.

Step  12 Using the File System Type pull-down menu, select ext3.

Step  13 In the Size (MB) field, select 100.

Step  14 In the Additional Size Options area, select Fixed size.

Step  15 Click OK.

Step  16 Click New.

Step  17 Type / in the Mount Point field.

Step  18 Using the File System Type pull-down menu, select ext3.

Step  19 In the Size (MB) field, select 8000.

Step  20 In the Additional Size Options area, select Fixed size.

Step  21 Click OK.

Step  22 Click New.

Step  23 In the Mount Point field type /dev/shm.

Step  24 Using the File System Type pull-down menu, select ext3.

Step  25 In the Size (MB) field, select 1024.

Step  26 In the Additional Size Options area, select Fixed size.

Step  27 Click OK.

Step  28 Click New.

Step  29 Using the File System Type pull-down menu, select swap.

Step  30 In the Size (MB) field, select 2048.

Step  31 In the Additional Size Options area, select Fixed size.

Step  32 Click OK.

Step  33 Click New.

Step  34 Type /u in the Mount Point field.

Step  35 Using the File System Type pull-down menu, select ext3.
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Step  36 In the Additional Size Options area, select Fill to maximum allowable 
size.

Step  37 Click OK.

Step  38 Click Next. The Boot Loader Configuration screen displays.

Step  39 Click Change boot loader. 

Step  40 Select Use LILO as boot loader.

Step  41 Click OK.

Step  42 Click Next. The Network Configuration screen displays.

Step  43 If only one NIC card will be used, deselect eth1 in the Network Devices 
list. Skip this step of two NIC cards will be used.

Step  44 Click Next. The Firewall Configuration screen displays.

Step  45 Select No firewall and click Next. The Additional Language Support 
screen displays. 

Step  46 Verify that English (USA) is the only language selected and click Next. 
The Time Zone Selection screen displays.

Step  47 Scroll up and select your time zone. 

Step  48 Click Next. The Set Root Password screen displays.

Step  49 Type neax2400 in the Root Password field.

Step  50 Type neax2400 in the Confirm field.

Step  51 Click Next. The Package Installation screen displays.

Step  52 Click Customize the set of packages to be installed. The Package 
Group Selection screen displays.

Step  53  Select the following packages in each package group:

—Desktops 
• Select all packages

—Applications
• Editors
• Engineering and Scientific
• Graphical Internet
• Text-based Internet
• Office Productivity
• Sound and Video
• Graphics

—Servers
• Server Configuration Tools
• Web Server
• Windows File Server
• FTP Server
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• MySQL Database
Go into details and deselect all packages except for perl-DBD-
MySQL.Then, click OK to close the window.

• Network Server
• Legacy Network Server

Go into details and add telnet-server. Then, click OK to close the 
window.

—Development
• Select all packages

—System
• Select all packages

Step  54 Click Next. The About to Install screen displays. 

Step  55 Click Next. The system will begin installation.

Step  56 When the system ejects Disk 1, remove the disk and insert Disk 2. 

Step  57 Click OK. The system continues installation.

Step  58 When the system ejects Disk 2, remove the disk and insert Disk 3. 

Step  59 Click OK. The system continues installation.

Step  60 When the system ejects Disk 3, remove the disk and insert Disk 4. 

Step  61 Click OK. The system continues installation. 

Step  62 When the system ejects Disk4, remove the disk and insert Disk 1.

Step  63 Click OK. The Graphic Interface (X) Configuration screen displays.

Step  64 Using the Video Card RAM pulldown menu, select 64 MB and click 
Next. The Monitor Configuration screen displays. 

Step  65 Click Next (use the default settings). The Customize Graphical Conf. 
screen displays.

Step  66 Click Next (use the default settings).

Step  67 Remove installation Disk 1 and click Exit. The system will reboot.

Step  68 When the Welcome screen displays, click Next. The License Agreement 
screen displays.

Step  69 Select Yes, I agree to the license Agreement and click Next. The Date 
and Time screen displays.

Step  70 Set the correct date and time and click Next. The User Account screen 
displays. 

Step  71 Click Next.

Step  72 Click Continue.
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Step  73 Select No, I do not want to register my system for registration and 
click Next. The Additional CD screen displays.

Step  74 Click Next. The Finish Setup Screen displays.

Step  75 Click Next.

Step  76 Type root for the login name, then press Enter.

Step  77 Type neax2400 for the password, then press Enter.

Step  78 Click  in the bottom left corner of the screen.

Step  79 Select System Tools > Network Device Control.

Step  80 Highlight eth0 and click Configure. The Network Configuration window 
displays.

Step  81 Select eth0 and click Edit. The Ethernet Device window displays. 

Step  82 Select Statically set IP address.

Step  83 In the Address field, enter the server’s IP address.

Step  84 In the Subnet Mask field, enter the server’s Subnet Mask.

Step  85 In the Default Gateway Address field, enter the server’s Gateway 
address.

Step  86 Click OK.

Step  87 Highlight eth0 and click Activate. A question prompt displays.

Step  88 Click Yes. An information prompt displays.

Step  89 Click OK. The Network Configuration window displays.

Step  90 Close the Network Configuration window.

Step  91 In the Network Device Control window, verify that the status of eth0 is 
Active.

Step  92 Close the Network Device Control window.

Step  93 Click    and select Log Out.

Step  94 Select Save current settings and Restart the computer.

Step  95 Click OK. The server reboots.

Step  96 Type root for the login name, then press Enter.

Step  97 Type neax2400 for the password, then press Enter.

Step  98 Click  and select System Settings > Server Settings > Services. 
The Services Configuration window displays.

NOTE

If you want to get operating system updates from Red Hat, you must register later.



3-6         Installation

Global Navigator Server Installation Manual - Revision 4

Step  99 Scroll down and select telnet.

Step  100 Click Save and close the window.

------------------Procedure Complete------------------ 

Installing the Initio SCSI Driver (for Tape Backup)

For NEC 120Lg servers, use the following procedure to install the Initio 
SCSI driver.

Step  1 From the RedHat desktop, click  > System Tools > Terminal.

Step  2 Insert the Red Hat Enterprise Linux Installation CD 3 into the CD-ROM 
drive. 

Step  3 Do one of the following:

—If the system is not configured for automount, type mount /dev/cdrom 
and press Enter. Then, type cd /mnt/cdrom and press Enter.

—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

Step  4 Type cd RedHat/RPMS and press Enter.

Step  5 Type rpm –ivh kernel-smp-unsupported-2.4.21-4.EL.i686.rpm and 
press Enter.

Step  6 Type modprobe a100u2w and press Enter.

Step  7 Type lsmod and press Enter. A list displays.

Step  8 Verify a100u2w is in the list.

Step  9 Type cd /etc and press Enter.

Step  10 Type vi rc.sysinit and press Enter.

Step  11 Press Shift+g to go to the bottom of the file.

Step  12 Type a and press Enter.

Step  13 Use the right arrow key to go to the end of the last line.

Step  14 Press Enter to start a new line.

Step  15 Type modprobe a100u2w and press Enter.

Step  16 Press Esc.

Step  17 Type :.

Step  18 Type wq and press Enter. The server will now save the file.

Step  19 Reboot the server.

NOTE

If this server is an NEC 120Lg, proceed to Installing the Initio SCSI Driver (for Tape 
Backup).
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Step  20 Type root for the login name and press Enter.

Step  21 Type neax2400 for the password and press Enter.

Step  22 Click  > System Tools > Terminal.

Step  23 Type lsmod and press Enter.

Step  24 Verify that a100u2w is listed.

------------------Procedure Complete------------------

Installing the Global Navigator Server Software

Use the following procedure to install the Global Navigator 6.0 Server 
Software.

Step  1 Insert the Global Navigator 6.0 Server CD into the CD-ROM drive.

Step  2 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  3 Type root for the login name, then press Enter.

Step  4 Type neax2400 for the password, then press Enter.

Step  5 Do one of the following:

—If the system is not configured for automount, type mount /dev/cdrom 
and press Enter. Then, type cd /mnt/cdrom and press Enter.

—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

Step  6 To verify the CD-ROM is mounted, type ls. The contents of the CD-ROM 
are displayed.

Step  7 Type ./install and press Enter. The system begins installing the Global 
Navigator Server software.

Step  8 At the Do you want to install with existing database? prompt, type n 
and press Enter.

Step  9 At the Please enter site config level 1 password prompt, type this and 
press Enter.

Step  10 At the Please enter site config level 2 password prompt, type is and 
press Enter.

Step  11 At the Please enter site config level 3 password prompt, type secret 
and press Enter.

NOTE

Make sure you have available the appropriate Licensing Security Key (USB / 
Parallel) and the correct ACD IP Address. 

Global Navigator 6.0 will only run for 15 minutes without the correct Licensing 
information.



3-8         Installation

Global Navigator Server Installation Manual - Revision 4

Step  12 When the Site Config screen displays, select 4 for Set Switch, and press 
Enter.

Step  13 Arrow down to the Host Name field. 

Step  14 Enter the IP address of the ACD and press Enter.

Step  15 Press Esc twice.

Step  16 At the Do you want to setup automatic tape backup now (y/n)?, type 
y, then press Enter. The Java Runtime Environment loads.

Step  17 The next series of screens contain the License Agreement for the 
Security device (parallel or USB key). Press Spacebar to proceed 
through the screens.

Step  18 At the Do you Agree with the License (y/n) prompt, enter y and press 
Enter.

Step  19 At the next prompt, select the number that represents the type of 
Licensing Security Key (USB / Parallel) and press Enter.

Step  20 When the Navigator Licensing tool interface appears, input any licenses 
you may have. 

Step  21 After entering all licenses, type q and press Enter to quit.

Step  22 At the Do you wish to enable pass through messages? (y/n), type N 
and press Enter.

Step  23 At the [root@localhost cdrom]# prompt, type cd / and press Enter.

Step  24 At the [root@localhost /]# prompt, type eject and press Enter.
The system ejects the CD-ROM. 

Step  25 Remove the CD-ROM.

The installation of Global Navigator server is now complete. The 
Navigator MIS service will now attempt to connect to ACD. If a valid 
download is received, Global Navigator is initialized and available for 
access by clients. 

To verify that the Global Navigator server is active, type 
netstat  -a | grep 0000 and press Enter. If port 50000 is displayed, 
the server is active and is up and available for access by clients. 

------------------Procedure Complete-----------------

TIP

You can run the Navigator Licensing tool at any time by invoking the keyutil utility 
from within the /u/acdmis/run directory.

IMPORTANT

If you are migrating from Global Navigator 3.x/4.x to Global Navigator 6.x, you must 
convert your database by completing the database conversion procedures in 
Chapter 4, Database and Hardware Conversion.
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Securing the Server

Use the information and steps in this section to configure the server for 
optimal security. Listening Endpoints details the ports used by the 
server. Maximizing Server Security provides the steps necessary to 
properly secure the server. 

Listening Endpoints
The server uses listening endpoints to listen for connection requests. 
When a request is received, the server processes the request to accept 
the connection. Table 3-1 lists the listening endpoints used.

Table 3-1  Listening Endpoints

Port Description
Global Navigator Server

3306 MySQL database

50000 Real-time

50003 Scheduled reports

50007 Configuration

50009 Reporting

60000 Administration

60007 Adminstration heartbeat

Virtual Wallboard Server

1945 Client

1900 Telnet administration

Infocast Server

1946 Client

NOTE

The Global Navigator server must also connect to the ACD. Depending on the type 
of the ACD, this is either a port in the range of 1024 to 1039 for external ACD, or a 
fixed port at 60040.
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Maximizing Server Security
The following procedure describes the steps necessary to maximize the 
security of the server running Global Navigator 6.0

Step  1 Log into the desktop environment as “root”, click the Red Hat icon, and 
select System Settings>Add/Remove Applications.

Step  2 Clear the check boxes beside the following packages:

Step  3 Click Details next to the Windows System package. The Windows 
Package Details screen displays.

Step  4 Click the checkboxes to match the settings in Figure 3-1 and Figure 3-2.

Figure 3-1  Window System Package Details 1

—Engineering & Scientific
—Text based Internet
—Office / Productivity
—Sound & Video
—Authoring & Publishing
—Games & Entertainment
—Web Server
—Mail Server
—Windows File Server

—DNS Name Server
—FTP Server
—SQL Database Server
—News Server
—Network Servers
—X Software Development
—GNOME Software 

Development
—KDE Software 

Development
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Figure 3-2  Window System Package Details 2

Step  5 Click Close.

Step  6 Click Details next to the GNOME Desktop Environment package. The 
GNOME Desktop Environment Details screen displays.

Step  7 Click the checkboxes to match the stettings in Figure 3-3, Figure 3-4, 
and Figure 3-5.

Figure 3-3  GNOME Desktop Environment Details 1
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Figure 3-4  GNOME Desktop Environment Details 2

Figure 3-5  GNOME Desktop Environment Details 3

Step  8 Click Close. 

Step  9 Click Details next to the KDE Desktop Environment package. The KDE 
Desktop Environment Details screen displays.

Step  10 Click the checkboxes to match the stettings in Figure 3-6.
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Figure 3-6  KDE Desktop Environment Details

Step  11 Click Close.

Step  12 Click Details next to the Editors package. The Editors Details screen 
displays.

Step  13 Click the checkboxes to match the stettings in Figure 3-7.

Figure 3-7  Editors Details

Step  14 Click Close.

Step  15 Click Details next to the Graphical Internet package. The Graphical 
Internet Details screen displays.

Step  16 Click the checkboxes to match the stettings in Figure 3-8.
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Figure 3-8  Graphical Internet Details

Step  17 Click Close.

Step  18 Click Details next to the Graphics package. The Graphics Package 
Details screen displays.

Step  19 Click the checkboxes to match the stettings in Figure 3-9.

Figure 3-9  Graphics Package Details

Step  20 Click Close.

Step  21 Click Details next to the Server Configuration Tools package. The Server 
Configuration Tools Details screen displays.

Step  22 Click the checkboxes to match the stettings in Figure 3-10.
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Figure 3-10  Server Configuration Tools Details

Step  23 Click Close.

Step  24 Click Details next to the Development Tools package. The Development 
Tools Details screen displays.

Step  25 Click the checkboxes to match the stettings in Figure 3-11 and 
Figure 3-12.

Figure 3-11  Development Tools Details 1
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Figure 3-12  Development Tools Details 2

Step  26 Click Close.

Step  27 Click Details next to the Kernel Development package. The Kernel 
Development Details screen displays.

Step  28 Click the checkboxes to match the stettings in Figure 3-13.

Figure 3-13  Kernel Development Details
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Step  29 Click Close.

Step  30 Click Details next to the Administration Tools package. The 
Administration Tools Details screen displays.

Step  31 Click the checkboxes to match the stettings in Figure 3-14.

Figure 3-14  Administration Tools Details

Step  32 Click Close.

Step  33 Click Details next to the System Tools package. The System Tools 
Details screen displays.

Step  34 Click the checkboxes to match the stettings in Figure 3-15.

Figure 3-15  System Tools Details
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Step  35 Click Close.

Step  36 Click Details next to the Printing Support package. The Printing Support 
Details screen displays.

Step  37 Click the checkboxes to match the stettings in Figure 3-16.

Figure 3-16   Printing Support Details

Step  38 Click Close.

Step  39 In the Package Management panel, after all the Select sub-packages 
match, click the Update button. When the update completes, exit the 
application.

Step  40 After removing the applications, you should click the Red Hat icon, and 
select System Settings>Server Settings>Services. The Service 
Configuration screenn displays (Figure 3-17).
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Figure 3-17  Service Configuration

Step  41 Check the following checkboxes to disable these services:

Step  42 After checking the appropriate boxes, select File>Save Changes.

Step  43 Exit and reboot the system.

—anacron
—atd
—autofs
—crond
—firstboot
—gnav
—gpm
—keytable

—kudzu
—network
—random
—rawdevices
—sgi_fam
—spix
—sshd
—syslog
—xinetd
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4
Database and Hardware Conversion

If you are migrating from Global Navigator 3.x, 4.x, or 5.x to Global 
Navigator 6.0, you must perform the appropriate steps in this chapter.

Topics in this chapter include:

Chapter topics • Global Navigator 3.x/4.x to 6.0 Hardware Conversion
• Database Conversion

— Database Conversion for 3.x or 4.x Database
— Database Conversion for 5.x Database

Global Navigator 3.x/4.x to 6.0 Hardware Conversion

Perform the following procedure if you are migrating from Global 
Navigator 3.x/4.x to Global Navigator 6.0 via the Server Hardware 
Conversion Kit.

Step  1 Perform a complete backup of the entire ACD-MIS system using 
bin/nav_help.

Step  2 After backup is complete, shutdown and power off the server.

Step  3 Carefully remove the old hard drive from the server.

Step  4 Properly mount the new hard drive in the mounting brackets of the 
server. 

Step  5 Power on the server.

Step  6 If prompted by Kudzu (the Linux hardware addition/deletion utility) to 
add/remove devices, add or remove the device(s) at the prompts 

NOTE

Conversion of report sets, scheduled reports, cyclical data and wallboard 
configuration is not supported.

NOTE

Printing from the Global Navigator server is not supported.
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(navigate through these screens by using arrow keys for direction and 
Enter to make the selections).

Step  7 If prompted to setup Networking, press Yes and Enter the IP information 
and the boot-up will continue.

Step  8 At the login prompt, type root for the user name and press Enter.

Step  9 Type neax2400 for the password and press Enter.

Step  10 Turn on Telnet by selecting Main Menu > System Settings > Server 
Settings > Services, check Telnet, then select File > Save Changes.
Telnet is now turned on.

Step  11 Type root for the login name, then press Enter.

Step  12 Type neax2400 for the password, then press Enter.

Step  13 Click  in the bottom left corner of the screen.

Step  14 Select System Tools > Network Device Control.

Step  15 Highlight eth0 and click Configure. The Network Configuration window 
displays.

Step  16 Select eth0 and click Edit. The Ethernet Device window displays. 

Step  17 Select Statically set IP address.

Step  18 In the Address field, enter the Server’s IP address.

Step  19 In the Subnet Mask field, enter the Server’s Subnet Mask.

Step  20 In the Default Gateway Address field, enter the Server’s Gateway 
address.

Step  21 Click OK.

Step  22 Highlight eth0 and click Activate. A question prompt displays.

Step  23 Click Yes. An information prompt displays.

Step  24 Click OK. The Network Configuration window displays.

Step  25 Close the Network Configuration window.

Step  26 In the Network Device Control window, verify that the status of eth0 is 
Active.

Step  27 Close the Network Device Control window.

Step  28 Click    and select Log Out.

Step  29 Select Save current settings and Restart the computer.

Step  30 Click OK. The server reboots.

Step  31 Follow the procedures in “Database Conversion for 3.x or 4.x Database” 
on page 4-3.

------------------Procedure Complete------------------



Database and Hardware Conversion         4-3

Global Navigator Server Installation Manual - Revision 4

Database Conversion

If you are migrating from Global Navigator 3.x , 4.x, or 5.x to Global 
Navigator 6.0 you must convert your current database by completing 
the following procedures.  

Database Conversion for 3.x or 4.x Database
Perform the following procedure if you currently are running Global 
Navigator 6.0 and need to migrate your 3.x or 4.x database to Global 
Navigator 6.0. 

Step  1 Reboot the Global Navigator server.

Step  2 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  3 Type root for the login name, then press Enter.

Step  4 Type neax2400 for the password, then press Enter.

Step  5 Change Directories to run. To do this type cd /u/acdmis/run and press 
Enter.

Step  6 Type /etc/init.d/gnav stop and press Enter to shutdown Global 
Navigator.

Step  7 Type cd /u/acdmis/run/config and press Enter

Step  8 Type cp activation.data / and press Enter. The license file is copied to 
the new directory. 

Step  9 Type cd .. and press Enter.

Step  10 Verify that you are at the u/acdmis/run directory. 

Step  11 Insert the Global Navigator 6.0 Server CD into the CD-ROM drive.

Step  12 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  13 Type root for the login name, then press Enter.

Step  14 Type neax2400 for the password, then press Enter.

Step  15 Do one of the following:

—If the system is not configured for automount, type mount /dev/cdrom 
and press Enter. Then, type cd /mnt/cdrom and press Enter.

—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

NOTE

The procedures in this section should be performed after the procedures in Chapter 
3, Installation.

NOTE

To prevent you from having to re-enter the license information later in this procedure, 
copy the license file to a different directory so it is not overwritten by the 3.x/4.x tape. 
Steps 7 and 8 show you how to copy the license file to a different directory.
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Step  16 To verify the CD-ROM is mounted, type ls and press Enter. The contents 
of the CD-ROM are displayed.

Step  17 Type ./install and press Enter. The system begins installing the Global 
Navigator server software.

Step  18 At the Do you want to install with existing database? prompt, type n 
and press Enter.

Step  19 At the Please Enter site config level 1 password prompt, type this and 
press Enter.

Step  20 At the Please Enter site config level 2 password prompt, type is and 
press Enter.

Step  21 At the Please Enter site config level 3 password prompt, type secret 
and press Enter.

Step  22 When the Site Config screen displays, select 4 for Set Switch, and press 
Enter.

Step  23 Arrow down to the Logging section and turn LOGGING on then arrow up 
to the Host Name field.

Step  24 Enter the IP address of the ACD and press Enter.

Step  25 Press Esc twice.

Step  26 At the Do you want to setup automatic tape backup now (y/n)?, type 
y, then press Enter. 

Step  27 The next series of screens contain the License Agreement for the Global 
Navigator Software. Press Spacebar to proceed through the screens.

Step  28 At the Do you Agree with the License (y/n) prompt, type y and press 
Enter.

Step  29 At the next prompt, type 3 to install both Sentinel Parallel and USB 
Daemon and press Enter.

Step  30 When the Navigator Licensing tool interface appears, press Ctrl+Alt+F2.

Step  31 At the login prompt, type root for the user name and press Enter.

Step  32 Type neax2400 for the password and press Enter.

Step  33 Type cd / and press Enter.

Step  34 Type cp activation.data /u/acdmis/run/config and press Enter.

Step  35 Press Ctrl+Alt+F1.

Step  36 On the License Information screen, select 3 and press Enter to verify the 
license is valid.

Step  37 If the license is valid, select 4 and press Enter to quit.

Step  38 At the [root@localhost cdrom]# prompt, type cd / and press Enter.

Step  39 At the [root@localhost/]# prompt, type eject and press Enter. The 
system ejects the CD-ROM.

Step  40 Remove the CD-ROM.
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Step  41 Type cd /u/acdmis/run/config and press Enter

Step  42 Type cp activation.data / and press Enter. The license file is copied to 
the new directory.

Step  43 Do one of the following depending on whether you want to convert the 
database via tape backup or FTP:

—For conversion via tape backup:
a) Insert the Tape of the Backed up 3.X or 4.X Data.
b) Type cd / and press Enter.
c) At the [root@localhost /]# prompt, type tar xvf /dev/st0 and 

press Enter.
d) Once the tape is extracted and you are back to the prompt, type 

cd /u/acdmis/run and press Enter. Remove the Tape and store in 
a safe place.

e) From the /u/acdmis/run directory, type script log.log and press 
Enter.

f) From the /u/acdmis/run directory, type 
./dbconversion MM/DD/YY and press Enter to run the 
conversion utility. If you do not want to specify a Stop Date for 
which the conversion will no longer convert Data, then type the 
following: ./dbconversion and press Enter.

—For conversion via FTP:

a) From the /u/acdmis/run directory, type script log.log and press 
Enter.

b) From the /u/acdmis/run directory, type 
./dbconversion MM/DD/YY ftp "server ip address" (where 
“server ip address” is the address of the server on which your 
database resides) and press Enter to run the conversion utility. If 
you do not want to specify a Stop Date for which the conversion 
will no longer convert Data then type the following: 
./dbconversion ftp "server ip address" and press Enter. The 
default user name that it will connect to is root and the password 
is neax2400. 

c) After the conversion utility is complete press Ctrl+d to stop the 
script.

Step  44 Insert the Global Navigator 6.0 Server CD into the CD-ROM drive.

Step  45 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  46 Type root for the login name, then press Enter.

Step  47 Type neax2400 for the password, then press Enter.

Step  48 Do one of the following:

—If the system is not configured for automount, type mount 
/dev/cdrom and press Enter. Then, type cd /mnt/cdrom and press 
Enter.

NOTE

If converting via FTP, the existing Unix Navigator server must be on the network and 
the new 5.0 Navigator server box must be able to connect to it. 
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—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

Step  49 To verify the CD-ROM is mounted, type ls and press Enter. The contents 
of the CD-ROM are displayed.

Step  50 Type ./install and press Enter. The system begins installing the Global 
Navigator server software.

Step  51 At the Do you want to install with existing database? prompt, type y 
and press Enter.

Step  52 At the Please Enter site config level 1 password prompt, type this and 
press Enter.

Step  53 At the Please Enter site config level 2 password prompt, type is and 
press Enter.

Step  54 At the Please Enter site config level 3 password prompt, type secret 
and press Enter.

Step  55 When the Site Config screen displays, select 4 for Set Switch, and press 
Enter.

Step  56 Arrow down to the Logging section and turn LOGGING on then arrow up 
to the Address field.

Step  57 Enter the IP address of the ACD and press Enter.

Step  58 Press Esc twice.

Step  59 At the Do you want to setup automatic tape backup now (y/n)?, type 
y, then press Enter.

Step  60 The next series of screens contain the License Agreement for the Global 
Navigator Software. Press Spacebar to proceed through the screens.

Step  61 At the Do you Agree with the License (y/n) prompt, type y and press 
Enter.

Step  62 At the next prompt, Enter 3 to install both Sentinel Parallel and USB 
Daemon and press Enter.

Step  63 When the Navigator Licensing tool interface appears, press Ctrl+Alt+F2.

Step  64 At the login prompt, type root for the user name and press Enter.

Step  65 Type neax2400 for the password and press Enter.

Step  66 Type cd / and press Enter.

Step  67 Type cp activation.data /u/acdmis/run/config and press Enter.

Step  68 Press Ctrl+Alt+F1.

Step  69 On the License Information screen, select the number that represents 
the type of Licensing Security Key (USB / Parallel) you have and press 
Enter to verify the license is valid.

Step  70 If the license is valid, select 4 and press Enter to quit.

Step  71 At the [root@localhost cdrom]# prompt, type cd / and press Enter.
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Step  72 At the [root@localhost/]# prompt, type eject and press Enter. The 
system ejects the CD-ROM.

Step  73 Remove the CD-ROM.

Step  74 Type reboot and press Enter to reboot the system.

------------------Procedure Complete------------------

Database Conversion for 5.x Database
If you are currently running Global Navigator 5.x, you will need to 
convert your database so that it is compatible with Global Navigator 6.0. 
Perform the following procedure if you are currently running Global 
Navigator 5.x and need to convert your database to 6.0.

Step  1 Backup the Global Navigator 5.x Database. 

Step  2 Insert a blank tape into the 5.x Server.

Step  3 Change the directory to run. To do this type cd /u/acdmis/run and press 
Enter.

Step  4 Type bin/nav_help and press Enter

Step  5 Choose option B and press Enter.

Step  6 Select option 3 and press Enter

Step  7 Once tape backup is completed remove the tape and store in a safe 
place.

Step  8 Complete the steps in “Installing the Linux Operating System” on page 3-
1.

Step  9 Complete the steps in “Installing the Global Navigator Server Software” 
on page 3-7 

Step  10 Insert the 5.x tape backup.  

Step  11 Change directory to /u/acdmis/run.

Step  12 Type bin/nav_help and press Enter.   

Step  13 Select B and press Enter.

Step  14 Select 4 (restore from tape) and press Enter.  

Step  15 After tape backup has completed, insert the Global Navigator 6.0 Server 
CD into the CD-ROM drive.

Step  16 Do one of the following:

NOTE

If there are multi-nodes in your ACD configuration, you will need to reconfigure these 
using the Navigator Utility (nav_help). See Chapter 6, Troubleshooting and 
Maintenance.
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—If the system is not configured for automount, type mount /dev/cdrom 
and press Enter. Then, type cd /mnt/cdrom and press Enter.

—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

Step  17 Type ./upgrade and press Enter. The system converts the 5.x database.

Step  18 When the conversion completes, remove the CD-ROM.

------------------Procedure Complete------------------

NOTE

If there are multi-nodes in your ACD configuration, you will need to reconfigure these 
using the Navigator Utility (nav_help). See Chapter 6, Troubleshooting and 
Maintenance.
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5
Peripherals

This chapter contains procedures for the following:

Chapter topics • Enable/Disable the Modem
• Installing Digiboards
• Configuring Wallboards
• Installing and Configuring Webmin

Enable/Disable the Modem

The following procedures detail how to enable and disable the modem in 
the server. 

Enable the Modem
Use the following procedure to enable the modem.

Step  1 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  2 Type root for the login name, then press Enter.

Step  3 Type cd /u/acdmis/run and press Enter.

Step  4 Type neax2400 for the password, then press Enter.

Step  5 At the [root@navigator root]# prompt, type ./modem.sh enable and 
press Enter.

Step  6 Type ttyS1 and press Enter.

------------------Procedure Complete-----------------

CAUTION

Enabling the modem without the modem being connected and powered on will 
cause error messages.
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Disable the Modem
Use the following procedure to disable the modem.

Step  1 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  2 Type root for the login name, then press Enter.

Step  3 Type neax2400 for the password, then press Enter.

Step  4 At the [root@navigator root]# prompt, type ./modem.sh disable and 
press Enter.

Step  5 Type ttyS1 and press Enter.

------------------Procedure Complete-----------------

Installing Digiboards

Global Navigator 6.0 can be configured to use two models of Digi 
boards: Digi AccelePort Xem Port/8em RJ45 and the Digi 
AccelePort Xp RJ45 (4 port).

The following procedures detail how to install the AccelePort Xem 
Digiboard and the Four port AccelePort Xp Digiboard.

AccelePort Xem Digiboard
The Digi AccelePort Xem Port/8em RJ45 with the AccelePort Xem Host 
Adapter-PCI was shipped with previous versions of Global Navigator. 

The following procedures detail the steps necessary to download the 
appropriate driver and install the Digi AccelePort Xem. 

Download AccelePort Xem Digiboard Driver
The following procedure details how to download the driver necessary to 
install the Digi AccelePort Xem.

Step  1 Using your PC internet connection go to www.digi.com/support.

Step  2 Use the Product List drop down list to select 
Acceleport Xem (8em,16em).

Step  3 Use the Supported Operating Systems to select Linux Red Hat ES 3.

Step  4 Click Submit.

Step  5 Select AccelePort Xem Host Adpt-PCI.

NOTE

If the driver file 40002347_a.src.rpm is not included on the Digi CD provided with the 
Digiboard, follow the steps in Download AccelePort Xem Digiboard Driver before 
installing the Digiboard.

http://support.digi.com


Peripherals         5-3

Global Navigator Server Installation Manual - Revision 4

Step  6 Download the driver 40002347_a.src.rpm to your PC and copy it to 
either a Floppy or CD-ROM.

Step  7 Proceed to Install AccelePort Xem Digiboard.

Install AccelePort Xem Digiboard
The following procedure details how to install the Digi AccelePort Xem on 
the Server.

Step  1 Shutdown and power off the Server.

Step  2 Install Digi AccelePort Xem hardware into the server per instructions 
provided with the Digi AccelePort Xem packaging.

Step  3 Power on server. During boot-up, Linux will detect the new hardware.

Step  4 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  5 Type root for the login name, then press Enter.

Step  6 Type neax2400 for the password, then press Enter.

Step  7 From the / directory, prepare for installation logging by typing 
script digi.log and press Enter.

Step  8 Insert the CD-ROM or Floppy containing the driver for this digiboard into 
the Server.

Step  9 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type mount /mnt/cdrom and press Enter.
—For Floppy, type mount /mnt/floppy and press Enter.

Step  10 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type cd /mnt/cdrom and press Enter.
—For Floppy, type cd /mnt/floppy and press Enter.

Step  11 Type cp 40002347_a.src.rpm / and press Enter.

Step  12 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type umount /mnt/cdrom and press Enter.
—For Floppy, type umount /mnt/floppy and press Enter.

Step  13 Step 13. Type cd / and press Enter.

Step  14 Remove the CD-ROM or Floppy from the Server.

Step  15 Type rpmbuild --rebuild --define DISTRO=REDHAT_ES_3 
40002347.a.src.rpm and press Enter.

NOTE

If the driver file 40002347_a.src.rpm is not included on the Digi CD provided with the 
Digiboard and you have not yet downloaded the driver, follow the steps in Download 
AccelePort Xem Digiboard Driver before installing the Digiboard.
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Step  16 Type cd  /usr/src/redhat/RPMS/i386 and press Enter.

Step  17 Type rpm -i dgap-1.1-1.i386.rpm and press Enter.

Step  18 Type mpi and press Enter.

Step  19 To navigate the mpi GUI use your up/down arrow keys.  

Step  20 Select Config and press Enter.

Step  21 Press Enter.

Step  22 Press Enter.

Step  23 Unless you are installing more than one digiboard select 1 adapter and 
press Enter.

Step  24 Select 2 AccelePort Xem PCI and press Enter.

Step  25 Select 1 module press Enter.

Step  26 Select the number of ports and press Enter.

Step  27 Select Yes and press Enter.

Step  28 Select Yes and press Enter.

Step  29 Select Yes and press Enter.

Step  30 Select Ok and press Enter.

Step  31 Select Exit and press Enter.

Step  32 Type chkconfig --add dgap and press Enter.

Step  33 Type reboot and press Enter.

------------------Procedure Complete-----------------

NOTE

To test the Digiboard ports, go to http://www.digi.com/support.

http://support.digi.com
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Four port AccelePort Xp Digiboard
The Digi AccelePort Xp RJ45 (4 port) is shipped with the Global 
Navigator 6.0 platform. This model does not have a separate Host 
Adapter. All RJ45 connections are built onto the board. 

The following procedures detail the steps necessary to download the 
appropriate driver and install the Digi AccelePort Xp. 

Download AccelePort Xp Digiboard Driver
The following procedure details how to download the driver necessary to 
install the AccelePort Xp.

Step  1 Using your PC internet connection go to www.digi.com/support.

Step  2 Use the Product List drop down list to select 
Acceleport Xp (2p,4p,8p,16p).  

Step  3 Use the Supported Operating Systems to select Linux Red Hat ES 3.

Step  4 Click Submit.

Step  5 Download the driver 40002059_h.src.rpm to your PC and copy it to 
either a Floppy or CD-ROM.

Step  6 Proceed to Install AccelePort Xp Digiboard.

Install AccelePort Xp Digiboard
The following procedure details how to install the four port Digi AccelePort 
Xp on the Server.

Step  1 Shutdown and power off the Server.

Step  2 Install Digi AccelePort Xp hardware into the server per instructions 
provided with the Digi AccelePort Xp packaging.

Step  3 Power on server. During boot-up, Linux will detect the new hardware.

Step  4 Let Kudzu configure the Digiboard card.

Step  5 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  6 Type root for the login name, then press Enter.

Step  7 Type neax2400 for the password, then press Enter.

Step  8 Insert the CD-ROM or Floppy containing the driver for this digiboard into 
the Server.

NOTE

If the driver file 40002059_h_src.rpm is not included on the Digi CD provided with 
the Digiboard, follow the steps in Download AccelePort Xp Digiboard Driver before 
installing the Digiboard.

NOTE

If the driver file 40002059_h_src.rpm is not included on the Digi CD provided with 
the Digiboard and you have not yet downloaded the driver, follow the steps in 
Download AccelePort Xp Digiboard Driver before installing the Digiboard.

http://support.digi.com
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Step  9 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type mount /mnt/cdrom and press Enter.
—For Floppy, type mount /mnt/floppy and press Enter.

Step  10 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type cd /mnt/cdrom and press Enter.
—For Floppy, type cd /mnt/floppy and press Enter.

Step  11 Type cp 40002059_h_src.rpm / and press Enter.

Step  12 Do one of the following depending on whether you are using a CD-ROM 
or Floppy:

—For CD-ROM, type umount /mnt/cdrom and press Enter.
—For Floppy, type umount /mnt/floppy and press Enter.

Step  13 Type cd / and press Enter.

Step  14 Remove the CD-ROM or Floppy from the Server.

Step  15 Type rpmbuild --rebuild --define DISTRO=REDHAT_ES_3 
40002059_h.src.rpm and press Enter.

Step  16 Change directory to the installation directory of the rpm.

Step  17 Type cd /usr/src/redhar/RPMS/i386 and press Enter.  

Step  18 Type rpm -ivv dgdm-1.1-1.i386.rpm and press Enter.

Step  19 After rpm installation is complete, type insmod dgdm and press Enter.

Step  20 Type chkconfig --add dgdm and press Enter.

Step  21 Reboot the Server.

Step  22 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  23 Type root for the login name, then press Enter.

Step  24 Type neax2400 for the password, then press Enter.

Step  25 Once the Server is up, verify the ports were installed by typing 
ls /dev/ttyG0* and press Enter. There should be four listed if the board 
is a 4-port board (/dev/ttyG0_00 - /dev/ttyG0_03)

Step  26 Press Ctrl+D to exit the startup script.

Step  27 Installation is complete.

------------------Procedure Complete-----------------

NOTE

To test the Digiboard ports, go to http://www.digi.com/support.

http://support.digi.com
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Configuring Wallboards

To configure wallboards, do the following: 

Step  1 Connect a serial cable from a serial Wallboard to a Digiboard port on the 
Global Navigator server.

Step  2 Launch GNAV Pro on your PC.

Step  3 Do one of the following:

—Select Maintenance > Wallboard Configuration. 

—Click  on the toolbar. 
The Wallboard Configuration dialog displays (Figure 5-1).

Figure 5-1  Wallboard Configuration dialog

Step  4 Select the wallboard you wish to configure from the tree view display.

Step  5 Click the Serial Link Settings radio button.

Step  6 Type a port number in the TTY Port: field, then press Enter.

Step  7 Enter the serial number of your wallboard display in the Serial #: field.

Step  8 Select a baud rate from the Baud Rate: drop-down menu.

Step  9 Select ODD or EVEN from the Parity: drop-down menu.

Step  10 Select the number of data bits from the Data Bits: drop-down menu.

Step  11 Select the number of stop bits from the Stop Bits: drop-down menu.

NOTE

For more information, see the Global Navigator Online Help, accessible from the 
GNAV Pro application.
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Step  12 Select the version number of your wallboard from the Version #: drop-
down menu.

Step  13 Type the number of seconds in the Msg Delay: field to specify how long 
you woant the message to pause before displaying another message.

Step  14 Click OK to save your changes.

------------------Procedure Complete-----------------

Installing and Configuring Webmin

Webmin is a web-based Linux administration program that provides 
remote maintenance access for the Global Navigator server.

Installing Webmin
Use the following procedure to install the Webmin Software.

Step  1 Insert the Webmin CD into the CD-ROM drive.

Step  2 At the login dialog, press Ctrl+Alt+F1. A text interface window displays.

Step  3 Type root for the login name, then press Enter.

Step  4 Type neax2400 for the password, then press Enter.

Step  5 Do one of the following:

—If the system is not configured for automount, type mount /dev/cdrom 
and press Enter. Then, type cd /mnt/cdrom and press Enter.

—If the system is configured for automount, type cd /mnt/cdrom and 
press Enter.

Step  6 Type rpm -U webmin-1.150-1.noarch.rpm (this is case sensitive) and 
press Enter. The system begins installing the Webmin software.

Step  7  After installation is complete, type sync and press Enter.

Step  8 Type sync and press Enter.

Step  9 Type shutdown -y -g0 and press Enter.

Step  10 At the Power Down prompt, manually eject CD-ROM.

Step  11 Remove the CD-ROM.

NOTE

In order to connect to the Navigator server and use Webmin, you must setup a 
Dialup VPN on the GNAV Pro PC.
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Step  12 Reboot the system.

------------------Procedure Complete-----------------

Configuring Webmin
For Webmin to function properly, you must perform following 
configuration procedures.

Access Webmin

Step  1 From the Red Hat desktop, click the  button to start the web browser. 
The web browser displays.

Step  2 In the address bar of the browser, type http://localhost:10000 and press 
Enter. The Webmin login dialog box displays (Figure 5-2).

Figure 5-2  Webmin login dialog box

Step  3 Type root for the user name and neax2400 for the password, then press 
Enter. The Webmin window displays (Figure 5-3).

Figure 5-3  Webmin window

NOTE

Webmin installs to the /usr/libexec/webmin directory. The Administration User Name 
is root, and the default password is neax2400.
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Configuring the Modem
Do the following to configure the modem.

Step  1 From the main Webmin window, select Networking > PPP Dialin 
Server >Serial Port Configuration > Add a new Serial Port. The Serial 
Port Configuration window displays (Figure 5-4).

Figure 5-4  Serial Port Configuration window

Step  2 Enter the following.

Step  3 After making the appropriate settings, click Create. 

Step  4 Click Apply.

------------------Procedure Complete-----------------

Field / Setting Select / Enter
Serial Device Serial Port 2

Type Modem Connect

Port Speed Automatic Port Speed

Answer After 1 ring

Modem Mode Data only

Answer Ringback Within Disabled

Login Prompt Default
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Configuring PPP
Do the following to configure the PPP settings.

Step  1 From the main Webmin window, select Networking > PPP Dialin 
Server > PPP Option. The PPP Options window displays (Figure 5-5).

Figure 5-5  PPP Options window

Step  2 Enter the following (these are the only settings you need to make).

Step  3 After making the appropriate settings, click Save. The PPP Dialin Server 
window appears.

Step  4 Select PPP Accounts > Create new PPP account. The PPP Accounts 
window displays (Figure 5-6).

Figure 5-6  PPP Accounts window

Field / Setting Select / Enter
Automatically detect PPP... Yes

PPP IP addresses Enter your Local and Remote IP addresses
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Step  5 Enter the following.:

Step  6 After making the appropriate settings, click Save.

------------------Procedure Complete-----------------

Field / Setting Select / Enter
User Name root

Password neax2400

Server Any

Allow Any
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6
Troubleshooting and Maintenance

This chapter provides information on troubleshooting and maintenance 
of the Global Navigator 6.0 Server.

Chapter topics • Navigator Utility
• Backup/Restore 6.0 Database
• Stop/Start Global Navigator
• Global Navigator Resource and Download Verification
• Recover TCP/IP Connection

Navigator Utility

The Navigator Utility (nav_help) is allows you to perform many 
maintenance and configuration tasks. To access the utility, follow the 
procedure below.

Step  1 From the Linux desktop interface press Ctrl + Alt and F1.

Step  2 Type root for the login name, then press Enter.

Step  3 Type neax2400 for the password, then press Enter.

Step  4 Type cd /u/acdmis/run and press Enter.

Step  5 Type bin/nav_help and press Enter. The Navigator Utility screen 
displays with the available options (Figure 6-1).
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Figure 6-1  Navigator Utility

Backup/Restore 6.0 Database

Do the following to backup/restore the Global Navigator server 
database.

Step  1 From the Linux desktop interface press Ctrl + Alt and F1.

Step  2 Type root for the login name, then press Enter.

Step  3 Type neax2400 for the password, then press Enter.

Step  4 Type cd /u/acdmis/run and press Enter.

Step  5 Type bin/nav_help and press Enter. The Navigator Utility screen 
displays with the available options.

 B- Backup / Restore

 C- Network ACD conf [internal calls, next LWC, tracing]

 D- Downloaded ACD names [agent, split, pilot] synchronization

     Default values:

  

 NAME                     STATUS

 -----------------------------------------------

 Agent names / Initials   ACCEPTED

 Split names              ACCEPTED

 Pilot names              ACCEPTED

 E- IEX report options [list, resend, node & mapping]

 I- Tracking of Internal calls as Incoming

 L- Longest Waiting Call auto-cleaning timing

 M- Set Max. Queue Depth [to sync with ACD]

 N- Modify number of nodes monitored

 S- Configure the monitored nodes and MIS limits

 T- Configure tenant subscriptions for TCP/IP connectivity (number of tenants allowed 
   per node / 9 tenants per node maximum) 

 W- Configure Wall Display timing settings

  

      Default: 2.000 seconds

      Minimum: 0.100 seconds

      Maximum: 9.999 seconds

 J- Display running jobs

 K- Kill jobs

 U- Unlock configuration of monitored nodes and MIS limits
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Step  6 Type B for the Backup and Restore Databases and Directories and press 
Enter.

Step  7 Make the appropriate selection from the following options:

1 - Backup databases to hard disk
2 - Restore databases from hard disk
3 - Backup gnav server to tape
4 - Restore gnav server from tape
Q - exit

Step  8 When completed press Q to exit the Backup/Restore screen. The 
Navigator Utility screen displays.

Step  9 Press Q and then Enter. to exit.

------------------Procedure Complete------------------

Stop/Start Global Navigator

Use the following to start or stop Global Navigator from the root or run 
directory use the following 

To start:
At the root or run prompt, type /etc/init.d/gnav start and press 
Enter.

To stop:
At the root or run prompt, type /etc/init.d/gnav stop and press 
Enter.

NOTE

If this is the first time one of the options is selected, a message will display asking 
whether to create /u/acdmis/BACKUP. Answer yes to this question.
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Global Navigator Resource and Download Verification

Use the following procedures to verify that Global Navigator is running 
and a valid download has taken place.

Verify that Resource is running
Step  1 From the text-based interface, login as root.

Step  2 At the [root@navigator root]# prompt, type ps -ef | grep res and press 
Enter. Information similar to the following displays.

Line 1 = root 6064 0 jul08 00:00:00 ./RESOURCE
Line 2 = root 20579 3354 0 05:38 tty2 00:00:00 grep res

—The first line indicates that the Global Navigator application is running. 
If the entire line does not display, the application is not running.

—The second line echoes the terminal information that invoked the 
ps -ef | grep res command line. This line will always appear.

Verify a valid download
Step  1 From the text-based interface, login as root.

Step  2 At the root prompt type cd /u/acdmis/run and press the Enter. 
This will take you to the run directory.

Step  3 At the run directory, type tail -f swix.dat (where x equals the Node 
number) and press the Enter. 
If the download was successful, information similar to the following 
displays.

07:08:56< GE xxxxxxx
07:09:02< Gc 20030162358 
07:09:09< GB xxxxxxxxx

—GE indicates the start of download.
—Gc indicates the date and time change. 
—GB indicates download sequence complete. Indicates a successful 

download.

Note that you may not be able to see the GE event message. From the 
time that Navigator starts to the time that it may take you to run step 3 
above, the event message may have gone by. Look for the GB event 
message instead. This is a sure sign that the Download started and 
was completed. 

------------------Procedure Complete------------------
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Recover TCP/IP Connection

Global Navigator 6.0 has a built-in feature that allows it to recover the 
TCP/IP connection to the PBX(s) in the event of network failure. 

The following procedure demonstrates how to test and/or see how this 
feature works.

Step  1 Enter Terminal Mode and login to GNAV Pro. 

Step  2 Unplug the Ethernet cable from the NIC card on the Global Navigator 
server. The following occur:

—The terminal displays e100: eth0 NIC Link is Down.
—After 30 seconds, the GNAV Pro Real-time screen will go blank.

Step  3 Plug the Ethernet cable back into the NIC card. 
The following occur:

—The terminal displays e100: eth0 NIC Link is UP 100 Mbps Full 
Duplex.

—After 30 seconds, the GNAV Pro Real-time screen will show real-time 
data. 

------------------Procedure Complete------------------
NOTE

The amount of time for the system to reconnect is dependant upon the amount of 
network traffic. These times may vary.
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For additional information or support on this NEC Unified Solutions 
product, contact your NEC Unified Solutions representative.
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