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1
Introduction

This Infocast Administration Guide provides the information needed to 
operate the Infocast Administration application. The topics in this 
chapter include:

Chapter Topics • What is Infocast?
• How this Guide is Organized
• Using this Guide

What is Infocast?

Infocast is a productivity-based tool designed to allow NEC contact 
center users to view real-time queue statistics on the desktop. This 
enables users to react immediately to changes in call volume and agent 
availability to better serve customers.

Infocast gives users access to critical contact center statistics in a small 
window right on their workstations. While NEC's Virtual Wallboard 
application duplicates hardware wallboard statistics on the desktop, 
Infocast customizes this information for each user by displaying 
information that pertains to call activity for skill sets (splits) unique to 
that user.

Infocast displays call center information and statistics, such as:

• Abandoned percentage
• Calls in queue
• Grade of service
• Longest waiting call
• Number of agents in ready, break, work, and talk modes
• Split name
• Split number
• Total number of agents logged in

Using a local area network, Infocast links to an existing Global Navigator 
platform connected to a CallCenterWorX ACD to receive and display the 
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call center real-time queue statistics on each agent’s personal computer 
running the Infocast client.

How this Guide is Organized

Chapter 1
Introduction

This chapter provides a brief overview of the Infocast application, along 
with how this guide is organized and the document conventions. 

Chapter 2
Configuring Infocast

This chapter shows you how to perform the most common functions in 
the Infocast Administration application, including how to use the online 
Help. 

Using this Guide

This guide is designed to make the Infocast Administration application 
easy to use. This guide contains examples of installation screens and 
step-by-step instructions for the procedures you need to perform.

Document Conventions
This guide uses the following document conventions listed in Table 1-1:

Table 1-1  Document Conventions 

REFERENCE

Refer to the NEC Infocast Installation Guide for information on installing and 
configuring Infocast.

When you see It means Example

Boldfaced 

• Field names
• Button names
• Drop-down list names

• Commands, keywords, or 
other user input

Enter the ID in the Name field.
Click Save.
Select the names from the 
Employees drop-down list.
Enter login admin at the command 
prompt. 

Capitalized 

• Menu names
• Window names

• Dialog box names

From the File menu, choose Save.
From the Directory window, select 
Edit > Modify. 
Click OK to save and close the 
Account Properties dialog box.

Menu > Submenu
(boldfaced font)

• Menu paths Select Edit > Modify.
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Procedures
Step-by-step instructions are numbered. Simply follow the numbered 
steps to perform the desired function.

Sometimes in step-by-step instructions, you will have more than one 
option to complete the task. These options are presented as shown in 
the following example:

Step  1 Do one of the following to add a new employee to the Employee 
directory:

—Select the desired employee from the Name field and click Add.
—Double-click the desired employee from the Name field.
—To select all of the available names, click Add all.

Keyboard Conventions
The keys that may be used for this application are:

Table 1-2  Keyboard Conventions

CTRL+S
CTRL+Shift+S

• Shortcut keys Press CTRL+S to save your changes.

F2 • Function keys Press F1 to access the online Help. 

Click
Right-click

• Click the left mouse button
• Click the right mouse button

Click OK to save your changes. 
Right-click and select Delete from the 
shortcut menu.

When you see It means Example

Key Action
Arrow keys Scrolls among options within a menu or field.

Backspace Erases the character to the left of the cursor. 

Enter Accepts a selection or field entry. 

ESC Exits the current screen or action and moves to the previous screen 
or action.

Tab Moves forward through fields and options.

Shift+Tab Moves backward through fields and options.

CTRL+Tab Moves forward through tabs.

CTRL+Shift+Tab Moves backward through tabs.
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2
Configuring Infocast

The Infocast Administration application operates on a personal 
computer. This chapter describes the Infocast Administration 
application’s features and includes these topics:

Chapter Topics • Getting Started Using the Infocast Administration Application
• Configuring the Server
• Selecting Users
• Configuring Resource Users

Getting Started Using the Infocast Administration Application

This section details the Infocast Administration window, and contains 
the procedures used to:

• Set up the Infocast Administration Connection
• Start and exit the Infocast Administration application
• Access online Help

Setting up the Infocast Administration Connection
Before running the Infocast Administration for the first time, you must 
configure the connection to the server. Use the following steps to 
configure the Infocast Administration application’s server connection.

Step  1 From the Windows Start menu, select Programs > NEC Infocast 
Administration > NEC Infocast Administration Setup. The Infocast 
Setup dialog box displays (Figure 2-1).
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Figure 2-1  IP Setup - Infocast dialog

Step  2 Enter the Server IP address and Database port of the Infocast Server 
(Global Navigator Server).

Step  3 Select Default to use the default port assignment. To use a different port 
assignment, uncheck Default and enter the port number to assign.

Step  4 Click OK to save the settings and close the dialog box.

Starting Infocast Administration
Use the following steps to start the Infocast Administration application.

Figure 2-2  Starting Infocast Administration

Step  1 From the Windows desktop, select Start > Programs > NEC Infocast 
Administration > NEC Infocast Administration (Figure 2-2). The 
Infocast Login dialog box displays (Figure 2-3).
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Figure 2-3  Infocast Login dialog

Step  2 Enter your password and click OK. The Infocast Administration window 
displays (Figure 2-4).

Figure 2-4  Infocast Administration window 

Changing the Infocast Administration Password
You should change the default Administration password immediately 
after logging in to Infocast Administration the first time. Use the 
following steps to change the Administration password

Step  1 From the Administration - Infocast window, click Change Password. The 
The Change Password dialog box displays (Figure 2-5).

NOTE

The default password is password. You should change this default password 
immediately after logging in to Infocast Administration the first time. See “Changing 
the Infocast Administration Password” on page 3.
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Figure 2-5  Change Password dialog

Step  2 Enter the current password in the Old Password: field.

Step  3 Enter the new password in the New Password: field.

Step  4 Enter the new password again in the Confirm Password: field.

Step  5 Click OK to save the new password.

About the Infocast Administration Window
The Infocast Administration window (Figure 2-4) contains the following 
components:

Title Bar The Title Bar displays the name of the application.

Menu Bar The Menu Bar contains the available menus. Table 2-1 describes the 
commands contained in the menu. 

Table 2-1  Infocast Administration Menus 

Accessing Online Help
Online Help is available for Infocast Administration. The online Help 
contains a Contents listing, an Index, and a Search feature. Use these 
features to navigate to the desired Help topic. 

Use the following step to launch the Infocast online Help.

Step Select Help > Index. 

Menu Action

Help
• Access the online Help. 
• View information about the Infocast Administration version 

installed.
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Exiting Infocast Administration
Use the following step to disconnect from the server, exit the Infocast 
Administration application, and return to the Windows desktop. 

Step Do one of the following.

—Click the Exit button.
—Press ALT+F4. 
—Press ALT+x.
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Configuring the Server 

You can use Infocast’s Administration window (Figure 2-6) to view 
licensing information and the number of agents logged in, and to specify 
a server operating mode and alarm type. You can also configure how 
agent and split data display in the Infocast window, as well as specify 
alarm level values.

Figure 2-6  The Administration - Infocast window

Viewing the Licensing Information
The Agent Status box displays the maximum number of Infocast Client 
licenses and the number of agents currently connected (Figure 2-7).

Figure 2-7  Administration - Infocast window - Agent Status
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To view the licensing information, do the following:

Step  1 Launch the Infocast Administration client. The Infocast Login dialog box 
displays (Figure 2-3).

Step  2 Enter your password and click OK. The Infocast Administration window 
displays (Figure 2-6).

Step  3 Click Refresh to update the displayed information, as needed.

Modifying the Server Settings
The Server Status box (Figure 2-8) lets you select a server mode, and 
specify whether the levels needed to trigger Infocast alarms are the 
same as those set by Global Navigator MIS or custom levels of your 
choosing.

Figure 2-8  Administration - Infocast window - Server Status

About Server Modes
You can configure Infocast to operate in either of the following modes: 

Anonymous mode The Anonymous operating mode allows agents to start Infocast and 
receive statistics without entering an Agent ID and password. If Infocast 
is using Anonymous mode, the Infocast window displays immediately 
after launching the Infocast Client application from the desktop. 

Secure mode The Secure operating mode requires an agent to log in before receiving 
and displaying statistics. When this mode is selected, Infocast prompts 
the agent to enter their ID and password to access the Infocast window. 

NOTE

 Anonymous mode, which is also known as No Agent ID mode, is the default 
operating mode.
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Setting the Server Mode and Alarm Type
To modify the server settings do the following:

Step  1 From the Server Status box (Figure 2-8) in the Administration window, 
click the Modify button. The Modify Server Settings dialog (Figure 2-9) 
displays.

Figure 2-9  Modify Server Settings dialog

Step  2 Click a radio button to select a Server Mode:

—To require agents to log in before receiving and displaying statistics, 
select Secure Mode. 

—To allow agents to start Infocast and receive statistics without entering 
an Agent ID and password, select Anonymous Mode. 

—To disable logins to the Infocast Server, select Unavailable.

Step  3 Click a radio button to select an Alarm Type:

—To instruct the server to use alarms which can be configured with 
custom level values you determine, select Custom.

—To instruct the server to use level values obtained from Global 
Navigator MIS settings, select MIS.

Step  4 Click Save to save your changes.
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Configuring Custom Alarm Levels
The Custom Alarms dialog (Figure 2-12) contains the configuration 
settings for the custom alarm levels Infocast uses.

To configure the custom alarm level threshold values, do the following:

Step  1 Be sure you have assigned the custom Alarm Type in the Modify Server 
Settings dialog (Figure 2-9).

Step  2 From the Administration - Infocast window, click Select Splits. The 
Select Splits dialog displays (Figure 2-10 if only a single node is 
available, Figure 2-11 if multiple nodes are available).

Figure 2-10  Select Splits dialog (single node available)

NOTE

If you chose to use Global Navigator MIS alarms in the Modify Server Settings dialog 
(Figure 2-9), you must instead use Global Navigator to configure alarm levels. 
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Figure 2-11  Select Splits dialog (multiple nodes available)

Step  3 If your system contains multiple nodes, click the Select a node: 
dropdown menu and select the desired node. The Select a Split box lists 
the splits available in the selected node. 

Step  4 Select the split from the Select a Split box whose alarm levels you want 
to view or modify.

Step  5 Click the Alarms button. The Custom Alarm Levels dialog displays 
(Figure 2-12).

NOTE

The Alarms button does not display unless you selected the Custom Alarm type in 
the Modify Server Settings dialog. 
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Figure 2-12  Custom Alarm Levels dialog

Step  6 Click a checkbox to enable each alarm, as needed.

Step  7 Enter a custom value for each Level 1 and Level 2 alarm, as needed.

Step  8 Click Save to save the custom alarm values. 

NOTE

For more information about configuring Level 1 and Level 2 alarms, please refer to 
the Global Navigator Online Help. 
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Selecting Users

You can select a list of users whose data will appear in the Infocast 
Client window, and select which of the available data columns display. 
Then, you can select splits for each user from a list of available splits.

Use the following steps to specify which data columns Infocast will 
display for a specific user, and to select the user’s available and 
configured splits. 

Step  1 From the Administration - Infocast window (Figure 2-6), click Select 
Users. The Select Users Display dialog displays (Figure 2-13 if only a 
single node is available, Figure 2-14 if multiple nodes are available).

Figure 2-13  Select Users Display dialog (single node available)
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Figure 2-14  Select Users Display dialog (multiple nodes available)

Step  2 If your system contains multiple nodes, click the Select a node: 
dropdown menu and select the desired node. The Select an Agent box 
lists the agents available in the selected node. 

Step  3 Select the agent from the Select an Agent box, then click Modify. The 
Modify Agent Display dialog displays (Figure 2-15).
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Figure 2-15  Modify Agent Display dialog

Step  4 Click checkboxes in the View Columns box to specify each data column 
Infocast will display for the selected user.

Step  5 Do one of the following:

—To add a split to a user, click a checkbox in the Splits Assigned to 
Agent box to select the desired split.

—To remove a split from a user, click its checkbox in the Splits 
Available for Viewing box to de-select it.

Step  6 The Splits Available for Viewing list contains the Split Parameters that 
Infocast can display to the agent. Select the check box next to the 
desired parameter to enable or disable the parameter for the agent. 

Step  7 Click Save to save your changes. 
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Configuring Resource Users

Resource Users exist only in Infocast; they do not have to be configured 
from within Global Navigator. Creating a Resource User is a good way to 
allow supervisors, administrators, and others with similar duties to view 
ACD statistics without creating an agent account.

Infocast Administration lets you add, modify, or delete Resource Users, 
as well as set passwords and assign splits to them.

Adding a New Resource User
To add a New Resource User, do the following:

Step  1 From the Administration - Infocast window (Figure 2-6), click Select 
Users. The Select Users Display dialog displays (Figure 2-13 if only a 
single node is available, Figure 2-14 if multiple nodes are available).

Step  2 In the Select a Resource User box, click New. The New Resource User 
dialog displays (Figure 2-16 if only a single node is available, Figure 2-17 
if multiple nodes are available).

Figure 2-16  New Resource User dialog (single node available)
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Figure 2-17  New Resource User dialog (multiple nodes available)

Step  3 Enter the new user’s name in the Name: field. 

Step  4 Enter an ID in the Login ID: field. 

Step  5 Click Set Password. The Set Password dialog displays (Figure 2-18). 

Figure 2-18  Set Password dialog

Step  6 Enter the user’s new password in the appropriate fields, then click OK.

Step  7 If your system contains multiple nodes, click the Select a node: 
dropdown menu and select the desired node. The Available Splits box 
lists the splits available in the selected node. 

Step  8 To add a split to this user, select the desired split from the Available 
Splits list.

Step  9 Click  to move the splits to the Selected Splits list. (Use  to 
remove splits from the Selected Splits list.)

Step  10 Click Save to save your changes. 
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Modifying a Resource User
To modify a Resource User, do the following:

Step  1 From the Administration - Infocast window (Figure 2-6), click Select 
Users. The Select Users Display dialog displays (Figure 2-13 if only a 
single node is available, Figure 2-14 if multiple nodes are available).

Step  2 In the Select a Resource User box, select the resource users name and 
click Modify. The Modify Resource User dialog displays (Figure 2-19 if 
only a single node is available, Figure 2-20 if multiple nodes are 
available).

Figure 2-19  Modify Resource User dialog (single node available)
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Figure 2-20  Modify Resource User dialog (multiple nodes available)

Step  3 Make any necessary changes to the name, Login ID, password, or splits 
for the selected user (If your system contains multiple nodes, click the 
Select a node: dropdown menu and select the desired node) then click 
Save to save the changes.

Deleting a Resource User
To delete a Resource User, do the following: 

Step  1 From the Administration - Infocast window (Figure 2-6), click Select 
Users. The Select Users Display dialog displays (Figure 2-13 if only a 
single node is available, Figure 2-14 if multiple nodes are available).

Step  2 In the Select a Resource User box, select the resource users name and 
click Delete. A delete confirmation dialog displays (Figure 2-21).

Figure 2-21  Delete Confirmation dialog

Step  3 Click Yes to delete the user.



For additional information or support on this NEC product,
contact your NEC representative.



Infocast Administration Guide

NDA-30240, Revision 2


	Introduction
	What is Infocast?
	How this Guide is Organized
	Using this Guide
	Document Conventions
	Procedures
	Keyboard Conventions


	Configuring Infocast
	Getting Started Using the Infocast Administration Application
	Setting up the Infocast Administration Connection
	Starting Infocast Administration
	Changing the Infocast Administration Password
	About the Infocast Administration Window
	Accessing Online Help
	Exiting Infocast Administration

	Configuring the Server
	Viewing the Licensing Information
	Modifying the Server Settings
	About Server Modes
	Setting the Server Mode and Alarm Type

	Configuring Custom Alarm Levels

	Selecting Users
	Configuring Resource Users
	Adding a New Resource User
	Modifying a Resource User
	Deleting a Resource User





